aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 2 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2af6d31..88737b4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,11 +1,10 @@
-# https://packaging.python.org/en/latest/tutorials/packaging-projects/#choosing-a-build-backend
[build-system]
requires = ["setuptools"]
build-backend = "setuptools.build_meta"
[project]
name = "skaldpress"
-version = "1.0.0" # REQUIRED, although can be dynamic
+version = "3.0.0"
description = ""
readme = "README"
requires-python = ">=3.10"
@@ -23,7 +22,7 @@ classifiers = [
"Programming Language :: Python :: 3.13",
"Programming Language :: Python :: 3 :: Only",
]
-dependencies = ["markdown", "py-gfm"]
+dependencies = ["markdown-it-py"]
[project.optional-dependencies]
dev = ["check-manifest", "black", "pyflakes", "mypy", "types-Markdown", "pyinstrument"]
@@ -36,4 +35,3 @@ test = ["coverage"]
smp = "smp:main"
skaldpress = "skaldpress.main:main"
-[tool.setuptools]