aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorQrius <[email protected]>2025-02-21 12:51:08 +0100
committerQrius <[email protected]>2025-02-21 12:51:11 +0100
commit5394cfcf6e0ab0d110429b22dffa7e8bd1cf39dc (patch)
tree748dc9a19cdc3e9910f832d1a7a1ba81acbe22e9 /pyproject.toml
downloadskaldpress-5394cfcf6e0ab0d110429b22dffa7e8bd1cf39dc.tar.gz
skaldpress-5394cfcf6e0ab0d110429b22dffa7e8bd1cf39dc.zip
first version of python rewrite
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e467c66
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,39 @@
+# https://packaging.python.org/en/latest/tutorials/packaging-projects/#choosing-a-build-backend
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "skaldpress"
+version = "1.0.0" # REQUIRED, although can be dynamic
+description = ""
+readme = "README"
+requires-python = ">=3.10"
+license = { file = "LICENSE" }
+authors = [{ name = "Qrius", email = "[email protected]" }]
+
+classifiers = [
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
+ "Programming Language :: Python :: 3.13",
+ "Programming Language :: Python :: 3 :: Only",
+]
+dependencies = ["markdown", "py-gfm"]
+
+[project.optional-dependencies]
+dev = ["check-manifest", "black"]
+test = ["coverage"]
+
+[project.urls]
+"Homepage" = "https://git.quirio.net/skaldpress"
+
+[project.scripts]
+smp = "smp:main"
+#skaldpress = "skaldpress:main"
+
+[tool.setuptools]