summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQrius <[email protected]>2024-09-26 00:11:06 +0200
committerQrius <[email protected]>2024-09-26 00:11:06 +0200
commit81affd4017870bd3f24a753bd4b937d86bd8da76 (patch)
tree936363e543f1b33b2fb88a7c24a12ea8526931de /Cargo.toml
parentc71bdceab75374edcb0e4de31c7907b5ef55bb4e (diff)
downloadskaldpress-81affd4017870bd3f24a753bd4b937d86bd8da76.tar.gz
skaldpress-81affd4017870bd3f24a753bd4b937d86bd8da76.zip
Add macro that checks whether links are working or not
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 30b051c..d0aa9b3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,13 +5,15 @@ edition = "2021"
default-run = "skaldpress"
[features]
-default = ["time", "markdown"]
+default = ["time", "markdown", "deadlinks"]
time = ["dep:chrono"]
markdown = ["dep:markdown"]
+deadlinks = ["dep:minreq"]
[dependencies]
markdown = { version = "1.0.0-alpha.20", optional = true }
chrono = { version = "0.4.38", optional = true }
+minreq = { version = "2.12.0", optional = true, features = ["https"] }
[[bin]]
name = "skaldpress"