diff options
author | Qrius <[email protected]> | 2024-12-06 14:23:32 +0100 |
---|---|---|
committer | Qrius <[email protected]> | 2024-12-06 14:23:41 +0100 |
commit | 1b59010b7da3b86aea6eb929d7efe37bdf735cd6 (patch) | |
tree | 568406b02dd280c005a54622b22a025776dcca9a /Cargo.toml | |
parent | 42ec0c6469238b60bfd5f5c0baa085ec0c6ec148 (diff) | |
download | skaldpress-1b59010b7da3b86aea6eb929d7efe37bdf735cd6.tar.gz skaldpress-1b59010b7da3b86aea6eb929d7efe37bdf735cd6.zip |
Add some basic bindings for Guile-3.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -5,16 +5,18 @@ edition = "2021" default-run = "skaldpress" [features] -default = ["time", "markdown", "deadlinks"] +default = ["time", "markdown", "deadlinks", "guile"] time = ["dep:chrono"] markdown = ["dep:markdown"] deadlinks = ["dep:minreq"] webring = [] +guile = [] [dependencies] markdown = { version = "1.0.0-alpha.20", optional = true } chrono = { version = "0.4.38", optional = true } minreq = { version = "2.12.0", optional = true, features = ["https", "punycode"] } +#libc = { version = "0.2.167", optional = true } [[bin]] name = "skaldpress" @@ -25,3 +27,7 @@ path = "src/skaldpress/main.rs" [[bin]] name = "smp" path = "src/macro_processor/main.rs" + +[[bin]] +name = "guiletest" +path = "src/guile/main.rs" |